[ACPI] Merge acpi-2.6.12 branch into 2.6.13-rc3
[linux-3.10.git] / drivers / acpi / pci_irq.c
index 7ed4b2ef265f10acb7c8636784a6066df1524009..c885300579eca17059688b47a115af937ad721ae 100644 (file)
@@ -466,8 +466,9 @@ acpi_pci_irq_enable (
                printk(KERN_WARNING PREFIX "PCI Interrupt %s[%c]: no GSI",
                        pci_name(dev), ('A' + pin));
                /* Interrupt Line values above 0xF are forbidden */
-               if (dev->irq >= 0 && (dev->irq <= 0xF)) {
+               if (dev->irq > 0 && (dev->irq <= 0xF)) {
                        printk(" - using IRQ %d\n", dev->irq);
+                       acpi_register_gsi(dev->irq, ACPI_LEVEL_SENSITIVE, ACPI_ACTIVE_LOW);
                        return_VALUE(0);
                }
                else {