selinux: sparse fix: fix several warnings in the security server code