HID: add compat support
[linux-2.6.git] / drivers / hid / Kconfig
index cacf89e65af4d9f96b1785c873b6f76b384775c3..d9d1a5671d957aab72011aed82055f3e695a9a67 100644 (file)
@@ -67,4 +67,43 @@ config HIDRAW
 
 source "drivers/hid/usbhid/Kconfig"
 
+menu "Special HID drivers"
+       depends on HID
+
+config HID_COMPAT
+       bool "Load all HID drivers on hid core load"
+       default y
+       ---help---
+       Compatible option for older userspace. If you have system without udev
+       support of module loading through aliases and also old
+       module-init-tools which can't handle hid bus, choose Y here. Otherwise
+       say N. If you say N and your userspace is old enough, the only
+       functionality you loose is modules autoloading.
+
+       If unsure, say Y.
+
+config HID_APPLE
+       tristate "Apple"
+       default m
+       depends on (USB_HID || BT_HIDP)
+       ---help---
+       Support for some Apple devices which less or more break
+       HID specification.
+
+       Say Y here if you want support for the special keys (Fn, Numlock) on
+       Apple iBooks, PowerBooks, MacBooks, MacBook Pros and aluminum USB
+       keyboards.
+
+       If unsure, say M.
+
+config HID_LOGITECH
+       tristate "Logitech"
+       default m
+       depends on USB_HID
+       ---help---
+       Support for some Logitech devices which breaks less or more
+       HID specification.
+
+endmenu
+
 endif # HID_SUPPORT