[PATCH] let SOUND_AD1889 depend on PCI
Adrian Bunk [Sat, 16 Apr 2005 22:25:59 +0000 (15:25 -0700)]
Compiling SOUND_AD1889 with PCI=n results in the following compile
error:

sound/built-in.o(.text+0x24f0c): In function `ad1889_remove':
: undefined reference to `pci_release_region'

This patch adds the missing dependency on PCI.

Signed-off-by: Adrian Bunk <bunk@stusta.de>
Signed-off-by: Andrew Morton <akpm@osdl.org>
Signed-off-by: Linus Torvalds <torvalds@osdl.org>

sound/oss/Kconfig

index d303c2e..a9602f8 100644 (file)
@@ -556,7 +556,7 @@ config SOUND_AD1816
 
 config SOUND_AD1889
        tristate "AD1889 based cards (AD1819 codec) (EXPERIMENTAL)"
-       depends on EXPERIMENTAL && SOUND_OSS
+       depends on EXPERIMENTAL && SOUND_OSS && PCI
        help
          Say M here if you have a sound card based on the Analog Devices
          AD1889 chip.