Fix host-libbfd installation problem caused by undefined $(INSTALL)
authorJim Huang <jim.huang@linaro.org>
Thu, 26 May 2011 17:24:34 +0000 (01:24 +0800)
committerJim Huang <jserv@0xlab.org>
Thu, 26 May 2011 17:25:31 +0000 (01:25 +0800)
commit7ee395d10100fc9ed2c03c49b949033600082a4f
tree0b2d233ffadee334ce820572e07cdb97b5e572c9
parentc8f863ea379ef46539fd3185a33f17220aab970e
Fix host-libbfd installation problem caused by undefined $(INSTALL)

While executing target install-host-libbfd, the build system complains:

make -C libbfd-binutils-2.20.1/bfd install \
               bfdlibdir=/tmp/android-toolchain-eabi/lib
bfdincludedir=/tmp/android-toolchain-eabi/include && \ -m 644
libbfd-binutils-2.20.1/intl/libintl.a \ /tmp/android-toolchain-eabi/lib
&& \ -m 644 libbfd-binutils-2.20.1/libiberty/libiberty.a \
               /tmp/android-toolchain-eabi/lib

/bin/sh: line 2: -m: command not found

The problem was caused by undefined $(INSTALL).  The patch attempts to
configure `install' program by autotool in order to set $(INSTALL)
properly and replace $(INSTALL) -m 644 with multi-platform friendly
$(INSTALL_DATA).

Change-Id: I7f08aa442d62f3d3d8cef2c482c76e6a93500de8
Signed-off-by: Jim Huang <jserv@0xlab.org>
Makefile.in
configure
configure.ac