arm gpio drivers: make them 'depends on ARM'
Linus Torvalds [Sun, 29 May 2011 21:06:42 +0000 (14:06 -0700)]
We had a few drivers move from arch/arm into drivers/gpio, but they
don't actually compile without the ARM platform headers etc.  As a
result they were messing up allyesconfig on x86.

Make them depend on ARM.

Reported-by: Ingo Molnar <mingo@elte.hu>
Cc: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

drivers/gpio/Kconfig

index 5923976..4a7f631 100644 (file)
@@ -89,24 +89,28 @@ config GPIO_IT8761E
 config GPIO_EXYNOS4
        bool "Samsung Exynos4 GPIO library support"
        default y if CPU_EXYNOS4210
+       depends on ARM
        help
          Say yes here to support Samsung Exynos4 series SoCs GPIO library
 
 config GPIO_PLAT_SAMSUNG
        bool "Samsung SoCs GPIO library support"
        default y if SAMSUNG_GPIOLIB_4BIT
+       depends on ARM
        help
          Say yes here to support Samsung SoCs GPIO library
 
 config GPIO_S5PC100
        bool "Samsung S5PC100 GPIO library support"
        default y if CPU_S5PC100
+       depends on ARM
        help
          Say yes here to support Samsung S5PC100 SoCs GPIO library
 
 config GPIO_S5PV210
        bool "Samsung S5PV210/S5PC110 GPIO library support"
        default y if CPU_S5PV210
+       depends on ARM
        help
          Say yes here to support Samsung S5PV210/S5PC110 SoCs GPIO library