block: don't select PERCPU_RWSEM
Mikulas Patocka [Thu, 21 Feb 2013 23:16:39 +0000 (15:16 -0800)]
The block device doesn't use percpu rw-semaphore anymore, so don't select
it for compilation.

Signed-off-by: Mikulas Patocka <mpatocka@redhat.com>
Cc: Jens Axboe <axboe@kernel.dk>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Jens Axboe <axboe@kernel.dk>

block/Kconfig

index 4a85ccf..a7e40a7 100644 (file)
@@ -4,7 +4,6 @@
 menuconfig BLOCK
        bool "Enable the block layer" if EXPERT
        default y
-       select PERCPU_RWSEM
        help
         Provide block layer support for the kernel.