ARM: tegra: T124: update l4t defconfig
Bibek Basu [Fri, 19 Jul 2013 09:43:29 +0000 (14:43 +0530)]
Enable TAEGRA_PCI & FRAMEBUFFER_CONSOLE
Enable TEGRA_AUTO_HOTPLUG
Enable ATA & SATA_AHCI_TEGRA

Bug 1323079

Change-Id: I15975afccda4a15b618a3572e31f0bd785d1144d
Signed-off-by: Bibek Basu <bbasu@nvidia.com>
Reviewed-on: http://git-master/r/251278
Reviewed-by: Automatic_Commit_Validation_User
Reviewed-by: Bharat Nihalani <bnihalani@nvidia.com>
Reviewed-by: Chetan Hooli <chooli@nvidia.com>
Tested-by: Chetan Hooli <chooli@nvidia.com>
Reviewed-by: Matthew Pedro <mapedro@nvidia.com>

arch/arm/configs/tegra12_defconfig

index c33c214..e75f571 100644 (file)
@@ -27,11 +27,11 @@ CONFIG_PARTITION_ADVANCED=y
 CONFIG_ARCH_TEGRA=y
 CONFIG_GPIO_PCA953X=y
 CONFIG_ARCH_TEGRA_12x_SOC=y
+CONFIG_TEGRA_PCI=y
 CONFIG_MACH_ARDBEG=y
 CONFIG_MACH_LAGUNA=y
 CONFIG_TEGRA_EMC_SCALING_ENABLE=y
 CONFIG_TEGRA_CLOCK_DEBUG_WRITE=y
-# CONFIG_TEGRA_AUTO_HOTPLUG is not set
 CONFIG_TEGRA_EDP_LIMITS=y
 CONFIG_USB_HOTPLUG=y
 CONFIG_TEGRA_DYNAMIC_PWRDET=y
@@ -195,12 +195,13 @@ CONFIG_TEGRA_BB_SUPPORT=y
 CONFIG_TEGRA_USB_MODEM_POWER=y
 CONFIG_TEGRA_BB_POWER=y
 CONFIG_TEGRA_BB_OEM1=y
-CONFIG_SCSI=y
 CONFIG_BLK_DEV_SD=y
 CONFIG_BLK_DEV_SR=y
 CONFIG_BLK_DEV_SR_VENDOR=y
 CONFIG_CHR_DEV_SG=y
 CONFIG_SCSI_MULTI_LUN=y
+CONFIG_ATA=y
+CONFIG_SATA_AHCI_TEGRA=y
 CONFIG_MD=y
 CONFIG_BLK_DEV_DM=y
 CONFIG_DM_CRYPT=y
@@ -324,7 +325,6 @@ CONFIG_REGULATOR_TPS80031=y
 CONFIG_REGULATOR_TPS6238X0=y
 CONFIG_REGULATOR_MAX77660=y
 CONFIG_MEDIA_SUPPORT=y
-CONFIG_VIDEO_HELPER_CHIPS_AUTO=y
 CONFIG_V4L_PLATFORM_DRIVERS=y
 # CONFIG_TEGRA_MEDIASERVER is not set
 CONFIG_TEGRA_NVAVP=y
@@ -352,6 +352,7 @@ CONFIG_LCD_CLASS_DEVICE=y
 CONFIG_BACKLIGHT_PWM=y
 CONFIG_BACKLIGHT_TEGRA_PWM=y
 CONFIG_BACKLIGHT_MAX8831=y
+CONFIG_FRAMEBUFFER_CONSOLE=y
 CONFIG_LOGO=y
 CONFIG_SOUND=y
 CONFIG_SND=y