Make BLK_DEV_BSG depend strictly on SCSI=y
Linus Torvalds [Mon, 16 Jul 2007 23:52:44 +0000 (16:52 -0700)]
The SCSI code can be compiled modular, but BLK_DEV_BSG currently cannot,
and depends on the SCSI layer.  So make sure that it depends on the SCSI
layer being compiled in, not just available as a module.

Noticed by Jeff Garzik and S.Çağlar Onur.

Cc: Jeff Garzik <jeff@garzik.org>
Cc: Jens Axboe <jens.axboe@oracle.com>
Cc: S.Çağlar Onur <caglar@pardus.org.tr>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

block/Kconfig

index 1d16b08..6597b60 100644 (file)
@@ -53,7 +53,7 @@ endif # BLOCK
 
 config BLK_DEV_BSG
        bool "Block layer SG support"
-       depends on SCSI && EXPERIMENTAL
+       depends on (SCSI=y) && EXPERIMENTAL
        default y
        ---help---
        Saying Y here will enable generic SG (SCSI generic) v4