MPI: Fix compilation on MIPS with GCC 4.4 and newer
authorManuel Lauss <manuel.lauss@gmail.com>
Thu, 22 Nov 2012 10:58:22 +0000 (11:58 +0100)
committerRalf Baechle <ralf@linux-mips.org>
Fri, 23 Nov 2012 17:57:17 +0000 (18:57 +0100)
commita3cea9894157c20a5b1ec08b7e0b5f2019740c10
treea1d319be7afd92637f89c5e6cbc2865b5cf908f6
parentf93a1a00f2bd550f86fd1a9f83c493755aecd15f
MPI: Fix compilation on MIPS with GCC 4.4 and newer

Since 4.4 GCC on MIPS no longer recognizes the "h" constraint,
leading to this build failure:

CC lib/mpi/generic_mpih-mul1.o
lib/mpi/generic_mpih-mul1.c: In function 'mpihelp_mul_1':
lib/mpi/generic_mpih-mul1.c:50:3: error: impossible constraint in 'asm'

This patch updates MPI with the latest umul_ppm implementations for MIPS.

Signed-off-by: Manuel Lauss <manuel.lauss@gmail.com>
Cc: Linux-MIPS <linux-mips@linux-mips.org>
Cc: Dmitry Kasatkin <dmitry.kasatkin@intel.com>
Cc: James Morris <jmorris@namei.org>
Patchwork: https://patchwork.linux-mips.org/patch/4612/
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
lib/mpi/longlong.h