lib: build list_sort() only if needed
[linux-3.10.git] / drivers / gpu / drm / Kconfig
1 #
2 # Drm device configuration
3 #
4 # This driver provides support for the
5 # Direct Rendering Infrastructure (DRI) in XFree86 4.1.0 and higher.
6 #
7 menuconfig DRM
8         tristate "Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)"
9         depends on (AGP || AGP=n) && PCI && !EMULATED_CMPXCHG && MMU
10         select I2C
11         select I2C_ALGOBIT
12         select LIST_SORT
13         help
14           Kernel-level support for the Direct Rendering Infrastructure (DRI)
15           introduced in XFree86 4.0. If you say Y here, you need to select
16           the module that's right for your graphics card from the list below.
17           These modules provide support for synchronization, security, and
18           DMA transfers. Please see <http://dri.sourceforge.net/> for more
19           details.  You should also select and configure AGP
20           (/dev/agpgart) support.
21
22 config DRM_KMS_HELPER
23         tristate
24         depends on DRM
25         select FB
26         select FRAMEBUFFER_CONSOLE if !EMBEDDED
27         help
28           FB and CRTC helpers for KMS drivers.
29
30 config DRM_TTM
31         tristate
32         depends on DRM
33         help
34           GPU memory management subsystem for devices with multiple
35           GPU memory types. Will be enabled automatically if a device driver
36           uses it.
37
38 config DRM_TDFX
39         tristate "3dfx Banshee/Voodoo3+"
40         depends on DRM && PCI
41         help
42           Choose this option if you have a 3dfx Banshee or Voodoo3 (or later),
43           graphics card.  If M is selected, the module will be called tdfx.
44
45 config DRM_R128
46         tristate "ATI Rage 128"
47         depends on DRM && PCI
48         select FW_LOADER
49         help
50           Choose this option if you have an ATI Rage 128 graphics card.  If M
51           is selected, the module will be called r128.  AGP support for
52           this card is strongly suggested (unless you have a PCI version).
53
54 config DRM_RADEON
55         tristate "ATI Radeon"
56         depends on DRM && PCI
57         select FB_CFB_FILLRECT
58         select FB_CFB_COPYAREA
59         select FB_CFB_IMAGEBLIT
60         select FW_LOADER
61         select DRM_KMS_HELPER
62         select DRM_TTM
63         help
64           Choose this option if you have an ATI Radeon graphics card.  There
65           are both PCI and AGP versions.  You don't need to choose this to
66           run the Radeon in plain VGA mode.
67
68           If M is selected, the module will be called radeon.
69
70 source "drivers/gpu/drm/radeon/Kconfig"
71
72 config DRM_I810
73         tristate "Intel I810"
74         depends on DRM && AGP && AGP_INTEL
75         help
76           Choose this option if you have an Intel I810 graphics card.  If M is
77           selected, the module will be called i810.  AGP support is required
78           for this driver to work.
79
80 choice
81         prompt "Intel 830M, 845G, 852GM, 855GM, 865G"
82         depends on DRM && AGP && AGP_INTEL
83         optional
84
85 config DRM_I830
86         tristate "i830 driver"
87         help
88           Choose this option if you have a system that has Intel 830M, 845G,
89           852GM, 855GM or 865G integrated graphics.  If M is selected, the
90           module will be called i830.  AGP support is required for this driver
91           to work. This driver is used by the older X releases X.org 6.7 and
92           XFree86 4.3. If unsure, build this and i915 as modules and the X server
93           will load the correct one.
94
95 config DRM_I915
96         tristate "i915 driver"
97         depends on AGP_INTEL
98         select SHMEM
99         select DRM_KMS_HELPER
100         select FB_CFB_FILLRECT
101         select FB_CFB_COPYAREA
102         select FB_CFB_IMAGEBLIT
103         # i915 depends on ACPI_VIDEO when ACPI is enabled
104         # but for select to work, need to select ACPI_VIDEO's dependencies, ick
105         select VIDEO_OUTPUT_CONTROL if ACPI
106         select BACKLIGHT_CLASS_DEVICE if ACPI
107         select INPUT if ACPI
108         select ACPI_VIDEO if ACPI
109         select ACPI_BUTTON if ACPI
110         help
111           Choose this option if you have a system that has Intel 830M, 845G,
112           852GM, 855GM 865G or 915G integrated graphics.  If M is selected, the
113           module will be called i915.  AGP support is required for this driver
114           to work. This driver is used by the Intel driver in X.org 6.8 and
115           XFree86 4.4 and above. If unsure, build this and i830 as modules and
116           the X server will load the correct one.
117
118 config DRM_I915_KMS
119         bool "Enable modesetting on intel by default"
120         depends on DRM_I915
121         help
122           Choose this option if you want kernel modesetting enabled by default,
123           and you have a new enough userspace to support this. Running old
124           userspaces with this enabled will cause pain.  Note that this causes
125           the driver to bind to PCI devices, which precludes loading things
126           like intelfb.
127
128 endchoice
129
130 config DRM_MGA
131         tristate "Matrox g200/g400"
132         depends on DRM
133         select FW_LOADER
134         help
135           Choose this option if you have a Matrox G200, G400 or G450 graphics
136           card.  If M is selected, the module will be called mga.  AGP
137           support is required for this driver to work.
138
139 config DRM_SIS
140         tristate "SiS video cards"
141         depends on DRM && AGP
142         depends on FB_SIS || FB_SIS=n
143         help
144           Choose this option if you have a SiS 630 or compatible video
145           chipset. If M is selected the module will be called sis. AGP
146           support is required for this driver to work.
147
148 config DRM_VIA
149         tristate "Via unichrome video cards"
150         depends on DRM
151         help
152           Choose this option if you have a Via unichrome or compatible video
153           chipset. If M is selected the module will be called via.
154
155 config DRM_SAVAGE
156         tristate "Savage video cards"
157         depends on DRM
158         help
159           Choose this option if you have a Savage3D/4/SuperSavage/Pro/Twister
160           chipset. If M is selected the module will be called savage.