ds2760_battery: Fix W1 and W1_SLAVE_DS2760 dependency
Martin Schwidefsky [Thu, 23 Sep 2010 13:21:36 +0000 (15:21 +0200)]
Fix this Kconfig warning on allmodconfig for s390:

warning: (BATTERY_DS2760 && POWER_SUPPLY) selects W1 which has unmet
direct dependencies (HAS_IOMEM)

Signed-off-by: Martin Schwidefsky <schwidefsky@de.ibm.com>
Signed-off-by: Anton Vorontsov <cbouatmailru@gmail.com>

drivers/power/Kconfig

index 4d9a637..0e98b20 100644 (file)
@@ -64,8 +64,7 @@ config TEST_POWER
 
 config BATTERY_DS2760
        tristate "DS2760 battery driver (HP iPAQ & others)"
-       select W1
-       select W1_SLAVE_DS2760
+       depends on W1 && W1_SLAVE_DS2760
        help
          Say Y here to enable support for batteries with ds2760 chip.