i2c-intel-mid: Driver depends on PCI
Randy Dunlap [Fri, 29 Oct 2010 20:37:09 +0000 (13:37 -0700)]
i2c-intel-mid driver uses PCI data structs and interfaces,
so it should depend on PCI.  Fixes these build errors:

drivers/i2c/busses/i2c-intel-mid.c:977: error: implicit declaration of function 'pci_request_region'
drivers/i2c/busses/i2c-intel-mid.c:1077: error: implicit declaration of function 'pci_release_region'

Signed-off-by: Randy Dunlap <randy.dunlap@oracle.com>
Cc: Ba Zheng <zheng.ba@intel.com>
Cc: Jean Delvare <khali@linux-fr.org>
Cc: Ben Dooks <ben-linux@fluff.org>
Cc: linux-i2c@vger.kernel.org
Signed-off-by: Ben Dooks <ben-linux@fluff.org>

drivers/i2c/busses/Kconfig

index 8fcdfba..175ba23 100644 (file)
@@ -398,6 +398,7 @@ config I2C_IMX
 
 config I2C_INTEL_MID
        tristate "Intel Moorestown/Medfield Platform I2C controller"
+       depends on PCI
        help
          Say Y here if you have an Intel Moorestown/Medfield platform I2C
          controller.