V4L/DVB: Deprecate cpia driver (used for parallel port webcams)
Mauro Carvalho Chehab [Thu, 30 Sep 2010 11:25:42 +0000 (08:25 -0300)]
cpia driver were re-written inside gspca driver, for USB devices. The only
functionality that were not migrated is the support for parallel port,
as:
1) the developer didn't find any hardware;
2) it doesn't  seem important to keep support for a parallel port webcam,
   as this is an obsolete technology;
3) the changes at gspca for it to work with parallel port would be very large;
4) this driver still uses BKL.

So, let's move it to drivers/staging and label it to die at 2.6.38, if nobody
cares enough to port parallel port support to gspca or to create a new driver
that uses the same gspca-cpia sub-driver.

Signed-off-by: Mauro Carvalho Chehab <mchehab@redhat.com>

12 files changed:
Documentation/feature-removal-schedule.txt
drivers/media/video/Kconfig
drivers/media/video/Makefile
drivers/staging/Kconfig
drivers/staging/Makefile
drivers/staging/cpia/Kconfig [new file with mode: 0644]
drivers/staging/cpia/Makefile [new file with mode: 0644]
drivers/staging/cpia/TODO [new file with mode: 0644]
drivers/staging/cpia/cpia.c [moved from drivers/media/video/cpia.c with 100% similarity]
drivers/staging/cpia/cpia.h [moved from drivers/media/video/cpia.h with 100% similarity]
drivers/staging/cpia/cpia_pp.c [moved from drivers/media/video/cpia_pp.c with 100% similarity]
drivers/staging/cpia/cpia_usb.c [moved from drivers/media/video/cpia_usb.c with 100% similarity]

index 2372fb2..4487225 100644 (file)
@@ -98,7 +98,7 @@ Who:  Pavel Machek <pavel@ucw.cz>
 ---------------------------
 
 What:  Video4Linux API 1 ioctls and from Video devices.
-When:  July 2009
+When:  kernel 2.6.38
 Files: include/linux/videodev.h
 Check: include/linux/videodev.h
 Why:   V4L1 AP1 was replaced by V4L2 API during migration from 2.4 to 2.6
@@ -116,6 +116,21 @@ Who:       Mauro Carvalho Chehab <mchehab@infradead.org>
 
 ---------------------------
 
+What:  Video4Linux obsolete drivers using V4L1 API
+When:  kernel 2.6.38
+Files: drivers/staging/cpia/*
+Check: drivers/staging/cpia/cpia.c
+Why:   There are some drivers still using V4L1 API, despite all efforts we've done
+       to migrate. Those drivers are for obsolete hardware that the old maintainer
+       didn't care (or not have the hardware anymore), and that no other developer
+       could find any hardware to buy. They probably have no practical usage today,
+       and people with such old hardware could probably keep using an older version
+       of the kernel. Those drivers will be moved to staging on 2.6.37 and, if nobody
+       care enough to port and test them with V4L2 API, they'll be removed on 2.6.38.
+Who:   Mauro Carvalho Chehab <mchehab@infradead.org>
+
+---------------------------
+
 What:  sys_sysctl
 When:  September 2010
 Option: CONFIG_SYSCTL_SYSCALL
index 2c0a8f7..4f21ef8 100644 (file)
@@ -599,46 +599,6 @@ config VIDEO_W9966
          Check out <file:Documentation/video4linux/w9966.txt> for more
          information.
 
-config VIDEO_CPIA
-       tristate "CPiA Video For Linux (DEPRECATED)"
-       depends on VIDEO_V4L1
-       default n
-       ---help---
-         This driver is DEPRECATED please use the gspca cpia1 module
-         instead. Note that you need atleast version 0.6.4 of libv4l for
-         the cpia1 gspca module.
-
-         This is the video4linux driver for cameras based on Vision's CPiA
-         (Colour Processor Interface ASIC), such as the Creative Labs Video
-         Blaster Webcam II. If you have one of these cameras, say Y here
-         and select parallel port and/or USB lowlevel support below,
-         otherwise say N. This will not work with the Creative Webcam III.
-
-         Please read <file:Documentation/video4linux/README.cpia> for more
-         information.
-
-         This driver is also available as a module (cpia).
-
-config VIDEO_CPIA_PP
-       tristate "CPiA Parallel Port Lowlevel Support"
-       depends on PARPORT_1284 && VIDEO_CPIA && PARPORT
-       help
-         This is the lowlevel parallel port support for cameras based on
-         Vision's CPiA (Colour Processor Interface ASIC), such as the
-         Creative Webcam II. If you have the parallel port version of one
-         of these cameras, say Y here, otherwise say N. It is also available
-         as a module (cpia_pp).
-
-config VIDEO_CPIA_USB
-       tristate "CPiA USB Lowlevel Support"
-       depends on VIDEO_CPIA && USB
-       help
-         This is the lowlevel USB support for cameras based on Vision's CPiA
-         (Colour Processor Interface ASIC), such as the Creative Webcam II.
-         If you have the USB version of one of these cameras, say Y here,
-         otherwise say N. This will not work with the Creative Webcam III.
-         It is also available as a module (cpia_usb).
-
 source "drivers/media/video/cpia2/Kconfig"
 
 config VIDEO_VINO
index a8f8989..b947160 100644 (file)
@@ -92,9 +92,6 @@ obj-$(CONFIG_VIDEO_W9966) += w9966.o
 obj-$(CONFIG_VIDEO_PMS) += pms.o
 obj-$(CONFIG_VIDEO_VINO) += vino.o
 obj-$(CONFIG_VIDEO_STRADIS) += stradis.o
-obj-$(CONFIG_VIDEO_CPIA) += cpia.o
-obj-$(CONFIG_VIDEO_CPIA_PP) += cpia_pp.o
-obj-$(CONFIG_VIDEO_CPIA_USB) += cpia_usb.o
 obj-$(CONFIG_VIDEO_MEYE) += meye.o
 obj-$(CONFIG_VIDEO_SAA7134) += saa7134/
 obj-$(CONFIG_VIDEO_CX88) += cx88/
index 335311a..303c52c 100644 (file)
@@ -51,6 +51,8 @@ source "drivers/staging/cx25821/Kconfig"
 
 source "drivers/staging/tm6000/Kconfig"
 
+source "drivers/staging/cpia/Kconfig"
+
 source "drivers/staging/usbip/Kconfig"
 
 source "drivers/staging/winbond/Kconfig"
index e3f1e1b..ddcac24 100644 (file)
@@ -8,6 +8,7 @@ obj-$(CONFIG_SLICOSS)           += slicoss/
 obj-$(CONFIG_VIDEO_GO7007)     += go7007/
 obj-$(CONFIG_VIDEO_CX25821)    += cx25821/
 obj-$(CONFIG_VIDEO_TM6000)     += tm6000/
+obj-$(CONFIG_VIDEO_CPIA)       += cpia/
 obj-$(CONFIG_LIRC_STAGING)     += lirc/
 obj-$(CONFIG_USB_IP_COMMON)    += usbip/
 obj-$(CONFIG_W35UND)           += winbond/
diff --git a/drivers/staging/cpia/Kconfig b/drivers/staging/cpia/Kconfig
new file mode 100644 (file)
index 0000000..205d247
--- /dev/null
@@ -0,0 +1,39 @@
+config VIDEO_CPIA
+       tristate "CPiA Video For Linux (DEPRECATED)"
+       depends on VIDEO_V4L1
+       default n
+       ---help---
+         This driver is DEPRECATED please use the gspca cpia1 module
+         instead. Note that you need atleast version 0.6.4 of libv4l for
+         the cpia1 gspca module.
+
+         This is the video4linux driver for cameras based on Vision's CPiA
+         (Colour Processor Interface ASIC), such as the Creative Labs Video
+         Blaster Webcam II. If you have one of these cameras, say Y here
+         and select parallel port and/or USB lowlevel support below,
+         otherwise say N. This will not work with the Creative Webcam III.
+
+         Please read <file:Documentation/video4linux/README.cpia> for more
+         information.
+
+         This driver is also available as a module (cpia).
+
+config VIDEO_CPIA_PP
+       tristate "CPiA Parallel Port Lowlevel Support"
+       depends on PARPORT_1284 && VIDEO_CPIA && PARPORT
+       help
+         This is the lowlevel parallel port support for cameras based on
+         Vision's CPiA (Colour Processor Interface ASIC), such as the
+         Creative Webcam II. If you have the parallel port version of one
+         of these cameras, say Y here, otherwise say N. It is also available
+         as a module (cpia_pp).
+
+config VIDEO_CPIA_USB
+       tristate "CPiA USB Lowlevel Support"
+       depends on VIDEO_CPIA && USB
+       help
+         This is the lowlevel USB support for cameras based on Vision's CPiA
+         (Colour Processor Interface ASIC), such as the Creative Webcam II.
+         If you have the USB version of one of these cameras, say Y here,
+         otherwise say N. This will not work with the Creative Webcam III.
+         It is also available as a module (cpia_usb).
diff --git a/drivers/staging/cpia/Makefile b/drivers/staging/cpia/Makefile
new file mode 100644 (file)
index 0000000..89e52f1
--- /dev/null
@@ -0,0 +1,5 @@
+obj-$(CONFIG_VIDEO_CPIA) += cpia.o
+obj-$(CONFIG_VIDEO_CPIA_PP) += cpia_pp.o
+obj-$(CONFIG_VIDEO_CPIA_USB) += cpia_usb.o
+
+EXTRA_CFLAGS += -Idrivers/media/video
diff --git a/drivers/staging/cpia/TODO b/drivers/staging/cpia/TODO
new file mode 100644 (file)
index 0000000..ccb1c07
--- /dev/null
@@ -0,0 +1,8 @@
+This is an obsolete driver for some cpia-based webcams that use the parallel port.
+We couldn't find anyone with this hardware in order to port it to use V4L2.
+
+Also, parallel-port webcams are obsolete nowadays.
+
+If nobody take care on it, the driver will be removed for 2.6.38.
+
+Please send patches to linux-media@vger.kernel.org