Phonet: advise against enabling the pipe controller
Rémi Denis-Courmont [Fri, 8 Oct 2010 04:02:01 +0000 (04:02 +0000)]
As it currently is, the new code path is not compatible with existing
Nokia modems. This would break existing userspace for Nokia modem, such
as the existing oFono ISI driver.

Signed-off-by: Rémi Denis-Courmont <remi.denis-courmont@nokia.com>
Signed-off-by: David S. Miller <davem@davemloft.net>

net/phonet/Kconfig

index 901956a..a4fceb8 100644 (file)
@@ -24,4 +24,5 @@ config PHONET_PIPECTRLR
          data with Nokia Slim modems like WG2.5 used on ST-Ericsson U8500
          platform.
 
-         If unsure, say N.
+         This option is incompatible with older Nokia modems.
+         Say N here unless you really know what you are doing.