power_supply: bump EC version check that we refuse to run with in olpc_battery
Andres Salomon [Fri, 2 May 2008 20:41:59 +0000 (13:41 -0700)]
Refuse to run with an EC < 0x44.  We're playing it safe, and this is a pretty
old EC version.

Also, add a comment about why we're checking the EC version.

Signed-off-by: Andres Salomon <dilinger@debian.org>
Cc: David Woodhouse <dwmw2@infradead.org>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Anton Vorontsov <cbouatmailru@gmail.com>

drivers/power/olpc_battery.c

index d5fe6f0..c8b596a 100644 (file)
@@ -389,8 +389,14 @@ static int __init olpc_bat_init(void)
 
        if (!olpc_platform_info.ecver)
                return -ENXIO;
-       if (olpc_platform_info.ecver < 0x43) {
-               printk(KERN_NOTICE "OLPC EC version 0x%02x too old for battery driver.\n", olpc_platform_info.ecver);
+
+       /*
+        * We've seen a number of EC protocol changes; this driver requires
+        * the latest EC protocol, supported by 0x44 and above.
+        */
+       if (olpc_platform_info.ecver < 0x44) {
+               printk(KERN_NOTICE "OLPC EC version 0x%02x too old for "
+                       "battery driver.\n", olpc_platform_info.ecver);
                return -ENXIO;
        }