i2c-voodoo3: Deprecate in favor of tdfxfb
Jean Delvare [Mon, 13 Apr 2009 15:02:13 +0000 (17:02 +0200)]
Support for I2C/DDC was recently added to the tdfxfb driver, which
means that the i2c-voodoo3 driver can be deprecated.

Signed-off-by: Jean Delvare <khali@linux-fr.org>
Cc: Krzysztof Helt <krzysztof.h1@wp.pl>

Documentation/feature-removal-schedule.txt
drivers/i2c/busses/Kconfig

index 7e2af10..de491a3 100644 (file)
@@ -428,3 +428,12 @@ Why:       In 2.6.27, the semantics of /sys/bus/pci/slots was redefined to
        After a reasonable transition period, we will remove the legacy
        fakephp interface.
 Who:   Alex Chiang <achiang@hp.com>
+
+---------------------------
+
+What:  i2c-voodoo3 driver
+When:  October 2009
+Why:   Superseded by tdfxfb. I2C/DDC support used to live in a separate
+       driver but this caused driver conflicts.
+Who:   Jean Delvare <khali@linux-fr.org>
+       Krzysztof Helt <krzysztof.h1@wp.pl>
index 94eae5c..a48c8ae 100644 (file)
@@ -604,12 +604,14 @@ comment "Graphics adapter I2C/DDC channel drivers"
        depends on PCI
 
 config I2C_VOODOO3
-       tristate "Voodoo 3"
+       tristate "Voodoo 3 (DEPRECATED)"
        depends on PCI
        select I2C_ALGOBIT
        help
          If you say yes to this option, support will be included for the
-         Voodoo 3 I2C interface.
+         Voodoo 3 I2C interface. This driver is deprecated and you should
+         use the tdfxfb driver instead, which additionally provides
+         framebuffer support.
 
          This driver can also be built as a module.  If so, the module
          will be called i2c-voodoo3.