Only enable BLOCK_COMPAT if COMPAT is needed
Linus Torvalds [Sat, 13 Oct 2007 00:58:36 +0000 (17:58 -0700)]
IOW, it needs to depend on both CONFIG_BLOCK and CONFIG_COMPAT.

Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

block/Kconfig

index e108956..9bda7bc 100644 (file)
@@ -62,10 +62,11 @@ config BLK_DEV_BSG
        protocols (e.g. Task Management Functions and SMP in Serial
        Attached SCSI).
 
+endif # BLOCK
+
 config BLOCK_COMPAT
        bool
+       depends on BLOCK && COMPAT
        default y
 
-endif # BLOCK
-
 source block/Kconfig.iosched