ieee1394: change deprecation status of dv1394
Stefan Richter [Wed, 21 Mar 2007 23:40:06 +0000 (00:40 +0100)]
Nobody ported ffmpeg from dv1394 to rawiso yet, and there is no
justification to remove dv1394 right now.

Nevertheless, a strong deprecation of this ABI makes a lot of sense,
especially as Kristian H's drivers shape up to be an attractive
alternative to the existing ones.  But we don't have a schedule at the
moment.

Signed-off-by: Stefan Richter <stefanr@s5r6.in-berlin.de>

Documentation/ABI/obsolete/dv1394 [new file with mode: 0644]
Documentation/feature-removal-schedule.txt
drivers/ieee1394/Kconfig
drivers/ieee1394/dv1394.c

diff --git a/Documentation/ABI/obsolete/dv1394 b/Documentation/ABI/obsolete/dv1394
new file mode 100644 (file)
index 0000000..2ee3686
--- /dev/null
@@ -0,0 +1,9 @@
+What:          dv1394 (a.k.a. "OHCI-DV I/O support" for FireWire)
+Contact:       linux1394-devel@lists.sourceforge.net
+Description:
+       New application development should use raw1394 + userspace libraries
+       instead, notably libiec61883 which is functionally equivalent.
+
+Users:
+       ffmpeg/libavformat (used by a variety of media players)
+       dvgrab v1.x (replaced by dvgrab2 on top of raw1394 and resp. libraries)
index 0bc8b0b..19b4c96 100644 (file)
@@ -39,17 +39,6 @@ Who: Dan Dennedy <dan@dennedy.org>, Stefan Richter <stefanr@s5r6.in-berlin.de>
 
 ---------------------------
 
-What:  dv1394 driver (CONFIG_IEEE1394_DV1394)
-When:  June 2007
-Why:   Replaced by raw1394 + userspace libraries, notably libiec61883.  This
-       shift of application support has been indicated on www.linux1394.org
-       and developers' mailinglists for quite some time.  Major applications
-       have been converted, with the exception of ffmpeg and hence xine.
-       Piped output of dvgrab2 is a partial equivalent to dv1394.
-Who:   Dan Dennedy <dan@dennedy.org>, Stefan Richter <stefanr@s5r6.in-berlin.de>
-
----------------------------
-
 What:  Video4Linux API 1 ioctls and video_decoder.h from Video devices.
 When:  December 2006
 Why:   V4L1 AP1 was replaced by V4L2 API. during migration from 2.4 to 2.6
index b8a4734..cd84a55 100644 (file)
@@ -138,9 +138,9 @@ config IEEE1394_DV1394
        tristate "OHCI-DV I/O support (deprecated)"
        depends on IEEE1394 && IEEE1394_OHCI1394
        help
-         The dv1394 driver will be removed from Linux in a future release.
-         Its functionality is now provided by raw1394 together with libraries
-         such as libiec61883.
+         The dv1394 driver is unsupported and may be removed from Linux in a
+         future release.  Its functionality is now provided by raw1394 together
+         with libraries such as libiec61883.
 
 config IEEE1394_RAWIO
        tristate "Raw IEEE1394 I/O support"
index dee9529..026e38f 100644 (file)
@@ -2564,8 +2564,8 @@ static int __init dv1394_init_module(void)
        int ret;
 
        printk(KERN_WARNING
-              "WARNING: The dv1394 driver is unsupported and will be removed "
-              "from Linux soon. Use raw1394 instead.\n");
+              "NOTE: The dv1394 driver is unsupported and may be removed in a "
+              "future Linux release. Use raw1394 instead.\n");
 
        cdev_init(&dv1394_cdev, &dv1394_fops);
        dv1394_cdev.owner = THIS_MODULE;