[ARM] pxa: restrict availability of pxa2xx PCMCIA drivers
Russell King [Sat, 19 Apr 2008 15:46:54 +0000 (16:46 +0100)]
Not all PXA2xx platforms provide the necessary support files for
PCMCIA to work, let alone build.  Stop the build errors by making
PXA2xx PCMCIA support only available on those platforms which have
supplied the support files.

Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>

drivers/pcmcia/Kconfig

index 8b22281..ed8c069 100644 (file)
@@ -200,6 +200,7 @@ config PCMCIA_AU1X00
 config PCMCIA_SA1100
        tristate "SA1100 support"
        depends on ARM && ARCH_SA1100 && PCMCIA
+       depends on ARCH_LUBBOCK || MACH_MAINSTONE || PXA_SHARPSL || MACH_ARMCORE
        help
          Say Y here to include support for SA11x0-based PCMCIA or CF
          sockets, found on HP iPAQs, Yopy, and other StrongARM(R)/