drivers/base/node.c: fix compilation error with older versions of gcc
authorClaudio Scordino <claudio@evidence.eu.com>
Thu, 17 Nov 2011 10:08:32 +0000 (11:08 +0100)
committerGreg Kroah-Hartman <gregkh@suse.de>
Sat, 26 Nov 2011 17:08:36 +0000 (09:08 -0800)
commit5bccc0d01594bef09e120a2fe3e1d48a1d74bcfe
tree8dc4dac0ef5becbe2c2d337fe2dbfe318ac72874
parentc528b7244efaf55654b6a196234c1d3b43d29108
drivers/base/node.c: fix compilation error with older versions of gcc

commit 91a13c281d7d4648c0b32dede11a0144c4e7984c upstream.

Patch to fix the error message "directives may not be used inside a macro
argument" which appears when the kernel is compiled for the cris architecture.

Signed-off-by: Claudio Scordino <claudio@evidence.eu.com>
Acked-by: David Rientjes <rientjes@google.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
drivers/base/node.c