net: wireless: bcmdhd: Fix build break with newer versions of gcc
authorRom Lemarchand <rlemarchand@sta.samsung.com>
Wed, 13 Jul 2011 19:15:34 +0000 (12:15 -0700)
committerDan Willemsen <dwillemsen@nvidia.com>
Thu, 1 Dec 2011 05:38:50 +0000 (21:38 -0800)
commit3c01ad55ed0a11b249e07118fd083cfd185b185a
treedb3bd653068f0735b149a8e700923a5cb8f31cdf
parent756949b5987e41f70f3817af4b6bae0283caa28a
net: wireless: bcmdhd: Fix build break with newer versions of gcc

In case the WPA cipher can't be determined the pval and gval variables don't
get updated which generates a warning in newer versions of gcc (tested with
4.5.2). Since the bcmdhd driver gets compiled with warnings treated as errors
this change is needed to fix the build.

Change-Id: Ia483777fee54ac526bb0db7c666fa2bf5df17354
Signed-off-by: Rom Lemarchand <rlemarchand@sta.samsung.com>
drivers/net/wireless/bcmdhd/wl_cfg80211.c