net: wireless: bcm4329: Fix GCC 4.6 warning
authorDan Willemsen <dwillemsen@nvidia.com>
Thu, 8 Mar 2012 02:11:54 +0000 (18:11 -0800)
committerSimone Willett <swillett@nvidia.com>
Thu, 24 May 2012 18:19:31 +0000 (11:19 -0700)
commit3a8779385b7d191287f2e6e81fcc2dbcc1188869
treeecd27d7235e8b17d52c5c7b99b6b17d38e822ad8
parent1953361f8e492ea6ec5de23a5321a8eaf000563e
net: wireless: bcm4329: Fix GCC 4.6 warning

This module has -Werror turned on, so this was causing the build to
break on GCC 4.6:

drivers/net/wireless/bcm4329/wl_iw.c: In function 'wl_iw_set_pmksa':
drivers/net/wireless/bcm4329/wl_iw.c:5149:5: error: array subscript is above array bounds [-Werror=array-bounds]
drivers/net/wireless/bcm4329/wl_iw.c:5152:5: error: array subscript is above array bounds [-Werror=array-bounds]

It's a partial 'backport' of a change made to the bcmdhd driver:

commit 09a8dc7361d0e603d9935ec7f736fabaa2e6dc7a
net: wireless: bcmdhd: Combined P2P fix

Change-Id: Ie62ad82f884c213553772ac91eaf85e17a807503
Signed-off-by: Dan Willemsen <dwillemsen@nvidia.com>
Reviewed-on: http://git-master/r/88694
GVS: Gerrit_Virtual_Submit
Reviewed-by: Stephen Warren <swarren@nvidia.com>
drivers/net/wireless/bcm4329/wl_iw.c