kbuild: Fix compiler warning with assertion when calling 'fwrite'
[linux-2.6.git] / scripts / checkversion.pl
index ec7d211..5e490a8 100755 (executable)
@@ -5,23 +5,23 @@
 # including <linux/version.h> that don't need it.
 # Copyright (C) 2003, Randy Dunlap <rdunlap@xenotime.net>
 
+use strict;
+
 $| = 1;
 
-my $debugging = 0;
+my $debugging;
 
-foreach $file (@ARGV)
-{
+foreach my $file (@ARGV) {
+    next if $file =~ "include/linux/version\.h";
     # Open this file.
-    open(FILE, $file) || die "Can't open $file: $!\n";
+    open( my $f, '<', $file )
+      or die "Can't open $file: $!\n";
 
     # Initialize variables.
-    my $fInComment   = 0;
-    my $fInString    = 0;
-    my $fUseVersion   = 0;
+    my ($fInComment, $fInString, $fUseVersion);
     my $iLinuxVersion = 0;
 
-    LINE: while ( <FILE> )
-    {
+    while (<$f>) {
        # Strip comments.
        $fInComment && (s+^.*?\*/+ +o ? ($fInComment = 0) : next);
        m+/\*+o && (s+/\*.*?\*/+ +go, (s+/\*.*$+ +o && ($fInComment = 1)));
@@ -43,8 +43,8 @@ foreach $file (@ARGV)
        # Look for uses: LINUX_VERSION_CODE, KERNEL_VERSION, UTS_RELEASE
        if (($_ =~ /LINUX_VERSION_CODE/) || ($_ =~ /\WKERNEL_VERSION/)) {
            $fUseVersion = 1;
-           last LINE if $iLinuxVersion;
-       }
+            last if $iLinuxVersion;
+        }
     }
 
     # Report used version IDs without include?
@@ -67,5 +67,5 @@ foreach $file (@ARGV)
         }
     }
 
-    close(FILE);
+    close($f);
 }