V4L/DVB: Deprecate cpia driver (used for parallel port webcams)
[linux-2.6.git] / drivers / staging / cpia / Kconfig
1 config VIDEO_CPIA
2         tristate "CPiA Video For Linux (DEPRECATED)"
3         depends on VIDEO_V4L1
4         default n
5         ---help---
6           This driver is DEPRECATED please use the gspca cpia1 module
7           instead. Note that you need atleast version 0.6.4 of libv4l for
8           the cpia1 gspca module.
9
10           This is the video4linux driver for cameras based on Vision's CPiA
11           (Colour Processor Interface ASIC), such as the Creative Labs Video
12           Blaster Webcam II. If you have one of these cameras, say Y here
13           and select parallel port and/or USB lowlevel support below,
14           otherwise say N. This will not work with the Creative Webcam III.
15
16           Please read <file:Documentation/video4linux/README.cpia> for more
17           information.
18
19           This driver is also available as a module (cpia).
20
21 config VIDEO_CPIA_PP
22         tristate "CPiA Parallel Port Lowlevel Support"
23         depends on PARPORT_1284 && VIDEO_CPIA && PARPORT
24         help
25           This is the lowlevel parallel port support for cameras based on
26           Vision's CPiA (Colour Processor Interface ASIC), such as the
27           Creative Webcam II. If you have the parallel port version of one
28           of these cameras, say Y here, otherwise say N. It is also available
29           as a module (cpia_pp).
30
31 config VIDEO_CPIA_USB
32         tristate "CPiA USB Lowlevel Support"
33         depends on VIDEO_CPIA && USB
34         help
35           This is the lowlevel USB support for cameras based on Vision's CPiA
36           (Colour Processor Interface ASIC), such as the Creative Webcam II.
37           If you have the USB version of one of these cameras, say Y here,
38           otherwise say N. This will not work with the Creative Webcam III.
39           It is also available as a module (cpia_usb).