CAPI: Silence lockdep warning on get_capi_appl_by_nr usage
[linux-2.6.git] / drivers / isdn / capi / Kconfig
1 config ISDN_DRV_AVMB1_VERBOSE_REASON
2         bool "Verbose reason code reporting"
3         default y
4         help
5           If you say Y here, the CAPI drivers will give verbose reasons for
6           disconnecting. This will increase the size of the kernel by 7 KB. If
7           unsure, say Y.
8
9 config CAPI_TRACE
10         bool "CAPI trace support"
11         default y
12         help
13           If you say Y here, the kernelcapi driver can make verbose traces
14           of CAPI messages. This feature can be enabled/disabled via IOCTL for
15           every controller (default disabled).
16           This will increase the size of the kernelcapi module by 20 KB.
17           If unsure, say Y.
18
19 config ISDN_CAPI_MIDDLEWARE
20         bool "CAPI2.0 Middleware support"
21         help
22           This option will enhance the capabilities of the /dev/capi20
23           interface.  It will provide a means of moving a data connection,
24           established via the usual /dev/capi20 interface to a special tty
25           device.  If you want to use pppd with pppdcapiplugin to dial up to
26           your ISP, say Y here.
27
28 config ISDN_CAPI_CAPI20
29         tristate "CAPI2.0 /dev/capi support"
30         help
31           This option will provide the CAPI 2.0 interface to userspace
32           applications via /dev/capi20. Applications should use the
33           standardized libcapi20 to access this functionality.  You should say
34           Y/M here.
35
36 config ISDN_CAPI_CAPIFS_BOOL
37         bool "CAPI2.0 filesystem support (DEPRECATED)"
38         depends on ISDN_CAPI_MIDDLEWARE && ISDN_CAPI_CAPI20
39         help
40           This option provides a special file system, similar to /dev/pts with
41           device nodes for the special ttys established by using the
42           middleware extension above.
43           You no longer need this, udev fully replaces it. This feature is
44           scheduled for removal.
45
46 config ISDN_CAPI_CAPIFS
47         tristate
48         depends on ISDN_CAPI_CAPIFS_BOOL
49         default ISDN_CAPI_CAPI20
50
51 config ISDN_CAPI_CAPIDRV
52         tristate "CAPI2.0 capidrv interface support"
53         depends on ISDN_I4L
54         help
55           This option provides the glue code to hook up CAPI driven cards to
56           the legacy isdn4linux link layer.  If you have a card which is
57           supported by a CAPI driver, but still want to use old features like
58           ippp interfaces or ttyI emulation, say Y/M here.