09aea5f1556da96d756c4ce04d104f226873c97f
[linux-2.6.git] / drivers / gpu / stub / Kconfig
1 config STUB_POULSBO
2         tristate "Intel GMA500 Stub Driver"
3         depends on PCI
4         # Poulsbo stub depends on ACPI_VIDEO when ACPI is enabled
5         # but for select to work, need to select ACPI_VIDEO's dependencies, ick
6         select BACKLIGHT_CLASS_DEVICE if ACPI
7         select INPUT if ACPI
8         select ACPI_VIDEO if ACPI
9         help
10           Choose this option if you have a system that has Intel GMA500
11           (Poulsbo) integrated graphics. If M is selected, the module will
12           be called Poulsbo. This driver is a stub driver for Poulsbo that
13           will call poulsbo.ko to enable the acpi backlight control sysfs
14           entry file because there have no poulsbo native driver can support
15           intel opregion.