ALSA: powermac - Replace the rest of __init*
[linux-2.6.git] / Documentation / Changes
1 Intro
2 =====
3
4 This document is designed to provide a list of the minimum levels of
5 software necessary to run the 2.6 kernels, as well as provide brief
6 instructions regarding any other "Gotchas" users may encounter when
7 trying life on the Bleeding Edge.  If upgrading from a pre-2.4.x
8 kernel, please consult the Changes file included with 2.4.x kernels for
9 additional information; most of that information will not be repeated
10 here.  Basically, this document assumes that your system is already
11 functional and running at least 2.4.x kernels.
12
13 This document is originally based on my "Changes" file for 2.0.x kernels
14 and therefore owes credit to the same people as that file (Jared Mauch,
15 Axel Boldt, Alessandro Sigala, and countless other users all over the
16 'net).
17
18 Current Minimal Requirements
19 ============================
20
21 Upgrade to at *least* these software revisions before thinking you've
22 encountered a bug!  If you're unsure what version you're currently
23 running, the suggested command should tell you.
24
25 Again, keep in mind that this list assumes you are already
26 functionally running a Linux 2.4 kernel.  Also, not all tools are
27 necessary on all systems; obviously, if you don't have any ISDN
28 hardware, for example, you probably needn't concern yourself with
29 isdn4k-utils.
30
31 o  Gnu C                  3.2                     # gcc --version
32 o  Gnu make               3.79.1                  # make --version
33 o  binutils               2.12                    # ld -v
34 o  util-linux             2.10o                   # fdformat --version
35 o  module-init-tools      0.9.10                  # depmod -V
36 o  e2fsprogs              1.41.4                  # e2fsck -V
37 o  jfsutils               1.1.3                   # fsck.jfs -V
38 o  reiserfsprogs          3.6.3                   # reiserfsck -V 2>&1|grep reiserfsprogs
39 o  xfsprogs               2.6.0                   # xfs_db -V
40 o  squashfs-tools         4.0                     # mksquashfs -version
41 o  btrfs-progs            0.18                    # btrfsck
42 o  pcmciautils            004                     # pccardctl -V
43 o  quota-tools            3.09                    # quota -V
44 o  PPP                    2.4.0                   # pppd --version
45 o  isdn4k-utils           3.1pre1                 # isdnctrl 2>&1|grep version
46 o  nfs-utils              1.0.5                   # showmount --version
47 o  procps                 3.2.0                   # ps --version
48 o  oprofile               0.9                     # oprofiled --version
49 o  udev                   081                     # udevinfo -V
50 o  grub                   0.93                    # grub --version
51
52 Kernel compilation
53 ==================
54
55 GCC
56 ---
57
58 The gcc version requirements may vary depending on the type of CPU in your
59 computer.
60
61 Make
62 ----
63
64 You will need Gnu make 3.79.1 or later to build the kernel.
65
66 Binutils
67 --------
68
69 Linux on IA-32 has recently switched from using as86 to using gas for
70 assembling the 16-bit boot code, removing the need for as86 to compile
71 your kernel.  This change does, however, mean that you need a recent
72 release of binutils.
73
74 System utilities
75 ================
76
77 Architectural changes
78 ---------------------
79
80 DevFS has been obsoleted in favour of udev
81 (http://www.kernel.org/pub/linux/utils/kernel/hotplug/)
82
83 32-bit UID support is now in place.  Have fun!
84
85 Linux documentation for functions is transitioning to inline
86 documentation via specially-formatted comments near their
87 definitions in the source.  These comments can be combined with the
88 SGML templates in the Documentation/DocBook directory to make DocBook
89 files, which can then be converted by DocBook stylesheets to PostScript,
90 HTML, PDF files, and several other formats.  In order to convert from
91 DocBook format to a format of your choice, you'll need to install Jade as
92 well as the desired DocBook stylesheets.
93
94 Util-linux
95 ----------
96
97 New versions of util-linux provide *fdisk support for larger disks,
98 support new options to mount, recognize more supported partition
99 types, have a fdformat which works with 2.4 kernels, and similar goodies.
100 You'll probably want to upgrade.
101
102 Ksymoops
103 --------
104
105 If the unthinkable happens and your kernel oopses, you may need the
106 ksymoops tool to decode it, but in most cases you don't.
107 In the 2.6 kernel it is generally preferred to build the kernel with
108 CONFIG_KALLSYMS so that it produces readable dumps that can be used as-is
109 (this also produces better output than ksymoops).
110 If for some reason your kernel is not build with CONFIG_KALLSYMS and
111 you have no way to rebuild and reproduce the Oops with that option, then
112 you can still decode that Oops with ksymoops.
113
114 Module-Init-Tools
115 -----------------
116
117 A new module loader is now in the kernel that requires module-init-tools
118 to use.  It is backward compatible with the 2.4.x series kernels.
119
120 Mkinitrd
121 --------
122
123 These changes to the /lib/modules file tree layout also require that
124 mkinitrd be upgraded.
125
126 E2fsprogs
127 ---------
128
129 The latest version of e2fsprogs fixes several bugs in fsck and
130 debugfs.  Obviously, it's a good idea to upgrade.
131
132 JFSutils
133 --------
134
135 The jfsutils package contains the utilities for the file system.
136 The following utilities are available:
137 o fsck.jfs - initiate replay of the transaction log, and check
138   and repair a JFS formatted partition.
139 o mkfs.jfs - create a JFS formatted partition.
140 o other file system utilities are also available in this package.
141
142 Reiserfsprogs
143 -------------
144
145 The reiserfsprogs package should be used for reiserfs-3.6.x
146 (Linux kernels 2.4.x). It is a combined package and contains working
147 versions of mkreiserfs, resize_reiserfs, debugreiserfs and
148 reiserfsck. These utils work on both i386 and alpha platforms.
149
150 Xfsprogs
151 --------
152
153 The latest version of xfsprogs contains mkfs.xfs, xfs_db, and the
154 xfs_repair utilities, among others, for the XFS filesystem.  It is
155 architecture independent and any version from 2.0.0 onward should
156 work correctly with this version of the XFS kernel code (2.6.0 or
157 later is recommended, due to some significant improvements).
158
159 PCMCIAutils
160 -----------
161
162 PCMCIAutils replaces pcmcia-cs (see below). It properly sets up
163 PCMCIA sockets at system startup and loads the appropriate modules
164 for 16-bit PCMCIA devices if the kernel is modularized and the hotplug
165 subsystem is used.
166
167 Pcmcia-cs
168 ---------
169
170 PCMCIA (PC Card) support is now partially implemented in the main
171 kernel source. The "pcmciautils" package (see above) replaces pcmcia-cs
172 for newest kernels.
173
174 Quota-tools
175 -----------
176
177 Support for 32 bit uid's and gid's is required if you want to use
178 the newer version 2 quota format.  Quota-tools version 3.07 and
179 newer has this support.  Use the recommended version or newer
180 from the table above.
181
182 Intel IA32 microcode
183 --------------------
184
185 A driver has been added to allow updating of Intel IA32 microcode,
186 accessible as a normal (misc) character device.  If you are not using
187 udev you may need to:
188
189 mkdir /dev/cpu
190 mknod /dev/cpu/microcode c 10 184
191 chmod 0644 /dev/cpu/microcode
192
193 as root before you can use this.  You'll probably also want to
194 get the user-space microcode_ctl utility to use with this.
195
196 Powertweak
197 ----------
198
199 If you are running v0.1.17 or earlier, you should upgrade to
200 version v0.99.0 or higher. Running old versions may cause problems
201 with programs using shared memory.
202
203 udev
204 ----
205 udev is a userspace application for populating /dev dynamically with
206 only entries for devices actually present.  udev replaces the basic
207 functionality of devfs, while allowing persistent device naming for
208 devices.
209
210 FUSE
211 ----
212
213 Needs libfuse 2.4.0 or later.  Absolute minimum is 2.3.0 but mount
214 options 'direct_io' and 'kernel_cache' won't work.
215
216 Networking
217 ==========
218
219 General changes
220 ---------------
221
222 If you have advanced network configuration needs, you should probably
223 consider using the network tools from ip-route2.
224
225 Packet Filter / NAT
226 -------------------
227 The packet filtering and NAT code uses the same tools like the previous 2.4.x
228 kernel series (iptables).  It still includes backwards-compatibility modules
229 for 2.2.x-style ipchains and 2.0.x-style ipfwadm.
230
231 PPP
232 ---
233
234 The PPP driver has been restructured to support multilink and to
235 enable it to operate over diverse media layers.  If you use PPP,
236 upgrade pppd to at least 2.4.0.
237
238 If you are not using udev, you must have the device file /dev/ppp
239 which can be made by:
240
241 mknod /dev/ppp c 108 0
242
243 as root.
244
245 Isdn4k-utils
246 ------------
247
248 Due to changes in the length of the phone number field, isdn4k-utils
249 needs to be recompiled or (preferably) upgraded.
250
251 NFS-utils
252 ---------
253
254 In 2.4 and earlier kernels, the nfs server needed to know about any
255 client that expected to be able to access files via NFS.  This
256 information would be given to the kernel by "mountd" when the client
257 mounted the filesystem, or by "exportfs" at system startup.  exportfs
258 would take information about active clients from /var/lib/nfs/rmtab.
259
260 This approach is quite fragile as it depends on rmtab being correct
261 which is not always easy, particularly when trying to implement
262 fail-over.  Even when the system is working well, rmtab suffers from
263 getting lots of old entries that never get removed.
264
265 With 2.6 we have the option of having the kernel tell mountd when it
266 gets a request from an unknown host, and mountd can give appropriate
267 export information to the kernel.  This removes the dependency on
268 rmtab and means that the kernel only needs to know about currently
269 active clients.
270
271 To enable this new functionality, you need to:
272
273   mount -t nfsd nfsd /proc/fs/nfsd
274
275 before running exportfs or mountd.  It is recommended that all NFS
276 services be protected from the internet-at-large by a firewall where
277 that is possible.
278
279 Getting updated software
280 ========================
281
282 Kernel compilation
283 ******************
284
285 gcc
286 ---
287 o  <ftp://ftp.gnu.org/gnu/gcc/>
288
289 Make
290 ----
291 o  <ftp://ftp.gnu.org/gnu/make/>
292
293 Binutils
294 --------
295 o  <ftp://ftp.kernel.org/pub/linux/devel/binutils/>
296
297 System utilities
298 ****************
299
300 Util-linux
301 ----------
302 o  <ftp://ftp.kernel.org/pub/linux/utils/util-linux/>
303
304 Ksymoops
305 --------
306 o  <ftp://ftp.kernel.org/pub/linux/utils/kernel/ksymoops/v2.4/>
307
308 Module-Init-Tools
309 -----------------
310 o  <ftp://ftp.kernel.org/pub/linux/kernel/people/rusty/modules/>
311
312 Mkinitrd
313 --------
314 o  <ftp://rawhide.redhat.com/pub/rawhide/SRPMS/SRPMS/>
315
316 E2fsprogs
317 ---------
318 o  <http://prdownloads.sourceforge.net/e2fsprogs/e2fsprogs-1.29.tar.gz>
319
320 JFSutils
321 --------
322 o  <http://jfs.sourceforge.net/>
323
324 Reiserfsprogs
325 -------------
326 o  <http://www.namesys.com/pub/reiserfsprogs/reiserfsprogs-3.6.3.tar.gz>
327
328 Xfsprogs
329 --------
330 o  <ftp://oss.sgi.com/projects/xfs/download/>
331
332 Pcmciautils
333 -----------
334 o  <ftp://ftp.kernel.org/pub/linux/utils/kernel/pcmcia/>
335
336 Pcmcia-cs
337 ---------
338 o  <http://pcmcia-cs.sourceforge.net/>
339
340 Quota-tools
341 ----------
342 o  <http://sourceforge.net/projects/linuxquota/>
343
344 DocBook Stylesheets
345 -------------------
346 o  <http://nwalsh.com/docbook/dsssl/>
347
348 XMLTO XSLT Frontend
349 -------------------
350 o  <http://cyberelk.net/tim/xmlto/>
351
352 Intel P6 microcode
353 ------------------
354 o  <http://www.urbanmyth.org/microcode/>
355
356 Powertweak
357 ----------
358 o  <http://powertweak.sourceforge.net/>
359
360 udev
361 ----
362 o <http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html>
363
364 FUSE
365 ----
366 o <http://sourceforge.net/projects/fuse>
367
368 Networking
369 **********
370
371 PPP
372 ---
373 o  <ftp://ftp.samba.org/pub/ppp/ppp-2.4.0.tar.gz>
374
375 Isdn4k-utils
376 ------------
377 o  <ftp://ftp.isdn4linux.de/pub/isdn4linux/utils/isdn4k-utils.v3.1pre1.tar.gz>
378
379 NFS-utils
380 ---------
381 o  <http://sourceforge.net/project/showfiles.php?group_id=14>
382
383 Iptables
384 --------
385 o  <http://www.iptables.org/downloads.html>
386
387 Ip-route2
388 ---------
389 o  <ftp://ftp.tux.org/pub/net/ip-routing/iproute2-2.2.4-now-ss991023.tar.gz>
390
391 OProfile
392 --------
393 o  <http://oprofile.sf.net/download/>
394
395 NFS-Utils
396 ---------
397 o  <http://nfs.sourceforge.net/>
398