Fix build to compile ppl > 0.11.2
Andrew Hsieh [Thu, 20 Dec 2012 08:33:28 +0000 (16:33 +0800)]
Provides library path for the new ppl 'configure' which needs
to links libgmp libgmpxx.

Also remove outdated --with-libgmp-prefix

Change-Id: I3be601c523fe1512e878a0aad632b9da2721c1bd

Makefile.in

index a838857..68f0f06 100644 (file)
@@ -667,7 +667,7 @@ config-host-ppl: stmp-config-host-ppl
 PPL_CONFIG_ARGS=$(host_baseargs) --prefix=$(TEMP_INSTALLDIR) --disable-shared \
          --target=${target_alias} \
          --host=${host} --build=${build} \
-         --disable-nls --with-libgmp-prefix=$(GMP_DIR) \
+         --disable-nls \
          --disable-watchdog --without-java \
          --disable-ppl_lcdd --disable-ppl_lpsol --disable-ppl_pips
 stmp-config-host-ppl: config.status stmp-install-host-gmp
@@ -677,6 +677,7 @@ stmp-config-host-ppl: config.status stmp-install-host-gmp
         cd ${PPL_VERSION} ; \
          export CFLAGS="${CFLAGS} -I$(GMP_DIR)/include" ; \
          export CXXFLAGS="${CFLAGS} -I$(GMP_DIR)/include" ; \
+         export LDFLAGS="${LDFLAGS} -L$(GMP_DIR)/lib" ; \
        $(call find-package-srcdir, ${PPL_VERSION})/configure \
         $(PPL_CONFIG_ARGS)) && \
        $(STAMP) $@